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Web Site Management with Microsoft's FrontPage 2003 
Presented by Roy D. Bailey, Jr., Bow School District,  rbailey@bownet.org  

Opening an existing site (Authors) 
When you launch FrontPage from the start menu, it opens with the last web site you edited already loaded. 
If it is the first time you ever opened a website, or if you need to edit multiple websites from the same 
computer, it is easiest to open the desired website in Internet Explorer first and then click on Internet 
Explorer’s “Edit” button which is normally located just to the right of the “print” button. 

  

Creating a New Site (Administrators Only) 
As the Web administrator, if you wish to add an additional sub-web site to your WWW server, you would 
load the <root web>, go to the File Menu, and select “Web” from the “New” submenu, You’d then select 
the appropriate template or wizard (Empty Web in this case) and enter the URL for the new website. By 
default, the new site has the same permission as the original “root” site. If you wish to have additional or 
different users author (or view) this new site, you'll need to access "Permissions" found in the “Security” 
submenu of the “Tools” menu and select "use unique permissions for this web". After you select “Apply” 
you can now change administration, author, and view permission for the new web site. If you have a 
Windows NT/2000 Domain, you can pull from its user list. Otherwise you’ll pull from the list of users on 
your web server. 

Editing the New Site (Administrators and Authors) 
You can change your view of your website by clicking on any of the icons located in the left vertical 
“Views” toolbar.  
 

• “Page” provides a view of the contents of the page you are working on.  
• “Folders” provides a view of the contents of the website you are working on. 
• “Reports” provides a view of the various reports you can run on the use and misuse of your 

website. 
• “Navigation” provides a view of the navigation structure of your web site which is very import 

should you make use of shared borders and themes. 
• “HyperLinks” provides a view of how you pages are linked to each other and other files locate in 

and out of your website. 
• “Tasks” provides a list of tasks which have been assigned by the various FrontPage wizards and/or 

tasks you assigned yourself as reminders. i.e. fix the broken hyperlink on page….. 
 
For simple editing of your website, you will primarily use the “Page” and “Folder” views.  
 
New “Empty” web sites are created with no pages. New pages can be created by selecting "New Page or 
Web" from the file menu. New "One Page Web" sites are created with one blank page named 
"Default.htm" which is saved to the location "website/subsite/default.htm". This page is the default page 
that will be loaded when a user accesses this new site. To edit any page, double click on its icon.  
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Adding Text 
If you've used word, you already know what you need to know. The tools from left to right are Style, Font, 
Font Size, Bold, Italics, Underline (hot keys also work), , Alignment (left, center, right), Increase/Decrease 
(PowerPoint), number list, bullet list, increase/decrease indent, Outside Borders, Highlight Color, and Text 
Color. Spell Check is still F7, most of the menus contain the same tools you’re already familiar with, etc… 
For basic web editing, if you already know Word, you already know 90% what you’ll need to know. 
 
 

 
 
 
Changing the Page's Appearance 
From "Page Properties" you can change the name of the page and its margins, color preferences, 
background image, etc… “Title” is found on the "General" tab, and color preferences can be found on the 
"Background" tab.  
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Example: To use a background image on the open page, you should: 
• select "Page Properties" (menu or right-click) 
• select the "Background" tab 
• activate the "Background Image" button 
• load/find/select image to use Browse Requester, the rough equivalent of the "open" requester in other 

applications, you are given the option of getting a file from either the "Current FrontPage Web", 
"Other Location" (File or Location), or "ClipArt".  
• You can use image formats other than GIF and JPEG. FrontPage will convert the file when you 

save the page. 

Saving a Page 
When you save a page that contains imported files like graphics, you will be prompted for a file name for 
each graphic. Important! Be careful to use unique file names (especially when importing translated Office 
files). FrontPage will not warn you when replacing existing files. 

Browsing a Page 
When in “Page” view, you have 3 ways to look at your work. You will usually work in the “normal” view, 
which allows you to edit the page. This is a static view and objects such as animated gifs won’t move and 
links will not work. If you switch page view into “preview” mode, your links will work and many objects 
such as animated gifs will now be animation. You cannot edit your page while in preview mode. There is 
also a html mode which will allow you to edit the html directly. 
 
To see what your page "really" looks like, you'll need to view it in a browser. Clicking on the “Preview in 
Browser” tool does this, or you can select the “Preview in Browser” from the “File” menu to pick your 
browser and the size of it’s window. 
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Adding Links  
Type the text use wish to "click" on and then select it. Click on the “Create or Edit Hyperlink” 
tool on the toolbar. You then need to pick from one of the available link types: “Current 
FrontPage Web” (the site you're working on), “World Wide Web” (any other web site), 

“Email”, or “New Page”. 
 

 
Adding Graphics 
 Get your cursor to the location you would like your graphic to appear and click on the "Insert Image" tool 
on the toolbar. You will then be presented with the same "Browse Requester" mentioned above. Select the 
desired graphic and click "okay". The graphic can then be formatted using the alignment tools on the tool 
bar and by "right" clicking on the graphic and selecting "Image Properties. 
 
Important! As you add multimedia to your web site, be mindful of the lower right side of the 
FrontPage window where the “time to download” information is displayed.  When you load 

large pictures, simply resizing them will not decrease you download time. You need 
to either resize them and then resample them with the resample tool or you could use the Auto-
Thumbnail Tool(found on the “Pictures Toolbar). 
 

Adding Line Breaks 
Place cursor where "Line Break" is to occur and select "Break" from the "insert" Menu. 
 
Adding Horizontal Lines 
Place the cursor where the "Horizontal Line" is to occur and select "Horizontal Line" from the "Insert" 
menu. 
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Adding Tables  
Place the cursor where the "Table" is to occur and click on the "Insert Table" tool on the toolbar. 
Choose the appropriate number of columns and rows (you can add/subtract later). The appearance 

of the table is adjusted by selecting the table and "right" clicking on it to adjust properties for the entire 
table (Table Properties" or individual cells of the table "Cell Properties". 
 

 
 

If you are trying to present data separated into cells, you may want the borders of your table to be visible. 
Example: You might want a calendar with visible cells that separate Monday, Tuesday, Wednesday, etc… 
To make your borders visible, select the table, open table properties and set Border Size to any number 
larger than 1. The larger the number; the thicker the border. You can also change the border’s color from 
this window. 
 
On the other hand, you might want your 
borders to be invisible. An invisible table 
is very handy when you want to mix text 
and graphics, or exercise a lot of control 
over how your document looks to the end 
user. To make your border invisible, 
select the table, go to table properties and 
set the border to “0”. 
 
You can also effect the formatting of any 
of the cells in a table by selecting the 
individual cell or cells and opening “cell 
properties”. Cell properties look and work 
a great deal like table properties. By 
default, tables have an equal number of 
columns for every row, and an equal number of rows for every column. This too can be changed to fit your 
needs by going to the “view” menu and selecting “tables” from the “toolbars” submenu. The “tables” 
toolbar gives you a pencil tool for adding additional divisions within existing cells and it gives you an 
erasing tool for removing existing divisions from cells. These two tools allow you to escape the creation of 
a table that looks like a grid or spreadsheet. It can be any shape you want it to be. 
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Another important concept to master in regards to tables and cells is the concept of “percentage vs. pixels”. 
By default, all table/cell width and height is based on a percentage of the end user’s browser’s window. 
Using our calendar as an example, by default its width is set to 100%.  
 
Thus on a small monitor (640x480) it would be shaped like this: 

 
On a larger monitor (1024x768) it would be shaped like this: 
 

 
To exact more control over how your website looks on all monitors, you can use tables to format your page 
and then format the table’s width and/or height to be a certain number of pixels instead of a certain 
percentage of the browser window size. If you format the table that holds your calendar to have a width of 
600 pixels, it will always look the same on any size monitor.
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Inserting Background Sound 
Background Sound playback is controlled from 
the "Page Properties" window. Press the 
Browse button to select the desire sound/midi 
file and then use the “loop” function to 
determine how long the sound plays.  
 
Important! Midi Files will download faster 
and usually provide better "bang for the buck", 
but they might not play back properly on all 
user workstations. 
 
Inserting Date and Time 
Select “date and time” from the “insert” menu 
in order to place a time stamp on your website 
that updates every time your page is updated. 
 

Cascading Style Sheets (CSS) in FrontPage 
 
Professionally designed websites display some consistency in design from page to page. For example, 
instead of your main page having a red background with white text while linking to a different page that 
has a blue background and yellow text, all the pages in the website would exhibit similar background and 
text attributes. 
 
While you could manually set these attributes page by page, there is an easier way. 
 

FrontPage 2002 and before: 
In FrontPage 2002 and earlier, you could setup your desired attributes in one page (ex. Default.htm) and 
then on each of the additional pages do the following: 

1) open page properties 
2) switch to the “Background” tab 
3) near the bottom of the window, check off  “Get background information from another page” and 

press “Browse” to select the page you want to get the attributes from (ex. Default.htm) 
4) repeat this process for all the other pages in your website 

 
As a result all of your pages will share the same attributes. In addition, any future changes you make to 
your master page (ex. Default.htm) will be reflected on all the pages that look to it for background 
information. 
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FrontPage 2003: 
In a shocking move for Microsoft, they have actually embraced standards and have replaced the method 
described above with Cascading Style Sheets (CSS). The bad news is that this is a little more involved to 
setup, but the good news is that it is more powerful and will work on none-Microsoft servers. 
 

1) select “new” from the “File” menu 
2) choose “more page templates”, switch to the “Style Sheets” tab and select “Normal Style Sheet” 
3) save the new page (notice that it has the extension .css) 
4) select “Style” from the “Format” menu and select the style you wish to format.  
5) Background and default text formatting can be found in the “body” style. Click on “format”, 

“border”, and “shading” to get to where you set the background. Click on “format”, and “font” to 
get to where you set the default text setting. 

6) “Link” formatting can be found in the “a:link” style. “Table” formatting can be found in the 
“table” style. 

7) Once you’ve defined your CSS style sheet you can apply it by selecting a page from your website 
and then selecting “Style Sheet Links” from the “format” menu. Press “Add” to select the desired 
style sheet. 

As a result all of your pages will share the same attributes. In addition, any future changes you make to 
your Style Sheet will be reflected on all the pages that look to it for background information. 
 
Inserting FrontPage Components 
FrontPage comes with a larger number of components you 
can insert by choosing “components” from the “insert” 
menu. Some popular choices include: 
• “hit counter” which allows you to keep track of the 

number of visitors your website has received. 
• “marquee” which place text scrolling in a marquee on 

your web page. 
• “search form” which allows end users to search you web 

site for particular information 
 
To insert a “hit counter”, select “Hit Counter” from the 
“Component” submenu of the “Insert” menu. In the resulting 
window, select the desired “counter style”, set the number 
you want to start with (assuming it isn’t “0”), set the number 
of digits you wish to display, and finish by pressing the 
“OK” button. 
 
To insert a “Marquee”, select “Marquee” from the 
“Component” submenu of the “Insert” menu. In the resulting 
window, enter the text you want see scroll into the “Text” window. You can then customize the appearance 
of the Marquee by selecting its direction, speed, behavior, alignment, etc… You change the background 
color from this window, but you’ll have to press the “style” button to change the text appearance by then 
pressing “format/font”. 
 
To insert a “Search Form”, select “Search Form” from the “Component” submenu of the “Insert” menu. In 
the resulting window, you set the labels for your form and buttons as well as define the number of 
characters allowed for input. Switch to the “Search Results” tab to define the parameters of the search such 
as what will be searched and what results will be displayed. 
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Important! Once you get into components, you’re starting to utilize proprietary Microsoft code. This is 
important to know since your web page will now have to be served on a Microsoft supported server (not a 
problem for school pages). More importantly, using these components may result in pages that appear and 
behave differently when viewed on anything other than a Windows based PC running Internet Explorer. So 
it will become important that you start viewing these pages in other ways, i.e. Netscape on Windows, 
Internet Explorer on Macintosh computers, Netscape on Macintosh computers, etc….. 
 
Adding Office 2003 Components 
  
Word 2003 
With the chosen document open in Word, select “Save as Web Page” from the “File” menu, and save it into 
a new folder. From FrontPage Explorer, choose “Import” from the “File” menu and then “Add Folder”. 
Place a link from your existing web site to the new word.htm. 
 
Excel 2003 
With the chosen worksheet open in Excel, select “Save as Web Page” from the “File” menu, and save it 
into a new folder. From FrontPage Explorer, choose “Import” from the “File” menu and then “Add 
Folder”. Place a link from your existing web site to the new excel.htm. 
 
PowerPoint 2003 
With the chosen presentation open in PowerPoint, select “Save as Web Page” from the “File” menu, and 
save it into a new folder. From FrontPage Explorer, choose “Import” from the “File” menu and then “Add 
Folder”. Place a link from your existing web site to the new presentation.htm. 

 
Maintaining Your Site 
Select “Recalculate Hyperlinks” from the “Tool” menu. After a moment, broken links will be presented in 
a window. From this window you may choose to ignore the problem, edit the link, or edit the page which 
the link occurs on. If you choose to edit the link, you'll have the option of having your "edit" occur on all 
other pages that contain the link. 


